So far my research has found that MAME versions greater than .117 (.118 and up) are not compatible with GlovePIE at all.  This seems to have something to do with GlovePIE’s support of multiple keyboards and how multiple keyboards were implemented after MAME .117.  I have yet to figure out any fixes or workarounds on my own nor have I found any solutions from other web pages or forums.

Fortunately JoyMonkey.com has an excellent archive of MAME versions.  If you want to GlovePIE to work, go download MAME .117 and you shouldn’t have any problems.

Related posts:

  1. MAME Project Step 1: The Basics This is a list of requirements for getting MAME going:...
  2. MAME Project Step 3: GlovePIE Now that the MSI Star Key 2.0 and BlueSoleil are...
  3. The MAME’ing of MediaPortal Since Carlos thinks I already spend too much time in...
  4. MAME Project Step 2: BlueSoleil & MSI Star Key The Widcomm drivers that come with the MSI Star Key...
  5. MAME Project Update Been running in to a few set backs with the...

6 Responses to “MAME .117+ and GlovePIE keyboard incompatibility”
  1. mame-mia says:

    hi,
    i have the same problem. Searching at all….
    Did you try to workaround mit ppjoy?
    thx
    Mame-Mia

  2. Len says:

    Hi Mame-Mia,
    No, I never found a proper fix for this problem. I did play with PPJoy a little but I decided that it was too much of a nuisance work-around. I’ll just stick with MAME .117 until a proper fix is found.

  3. CyberAxe says:

    Did you ever find a fix for this? i’ve been trying for hours to get it to work on version 0.133 even downloaded every alternative to glovepie pretty much and none of them even detect the wiimote

    Len Reply:

    No, never did find a solution but it’s been a while since I tried anything new. Please post back if you find a solution.

  4. alx3m says:

    Any good news? i want to play mame online whit my wiimote and it does not seems to work :S

  5. readyplayerone says:

    At some point, the developers of mame stopped allowing keystrokes to be sent from external applications. This was to support multiple keyboards and to prevent people using mame to build illegal cabinets. I didn’t even know people used mame to create illegal cabinets. I bought a griffin powermate (digital spinner) and need to run an older version of mame to get it to work properly. There appears to be no other solution for mame with the powermate.